Gatzet.com

Gadget, Free Software, Reviews

WordPress 2.3 Incompatibility Problem

September 28th, 2007 · 1 Comment

Only one day after WordPress version 2.3 released, we test it on our new easy diet blog. The installation process was working well and the blog was online using default themes.

However, when we start to change these default themes we were facing incompatibility problems on this version of wordpress. Right after we activated the new themes, we’re posting an article about easy way to succeed weight loss and when the auto save feature from WordPress were working automatically, suddenly an error message appeared on the editor.

WordPress database error: [Table 'wp_post2cat' doesn't exist]
SELECT p2c.category_id AS cat_id, COUNT(p2c.rel_id) AS numposts, UNIX_TIMESTAMP(max(posts.post_date_gmt)) + ’8′ AS last_post_date, UNIX_TIMESTAMP(max(posts.post_date_gmt)) AS last_post_date_gmt FROM wp_post2cat p2c INNER JOIN wp_posts posts ON p2c.post_id=posts.id WHERE 1 = 1 AND posts.post_type = ‘post’ AND posts.post_status = ‘publish’ AND posts.post_date_gmt <= '2007-09-19 12:08:25' GROUP BY p2c.category_id ORDER BY numposts DESC

According to WordPress support forums, this error appears because of some incompatible plugins. Example plugins which don’t work: Google Sitemaps Generator older than 3.0, Posts by Author plugin, and Ultimate Tag Warrior. Some themes also doesn’t work well with WordPress 2.3. You can check the list of compatible themes from WordPress.

Because of this problem, I suggest to try WordPress version 2.3 on subdomain or fresh installation. Beware if you want to upgrade your current WordPress engine with this latest version and make complete backup of your site before continuing upgrade.


Related posts:

  1. New WordPress Release
  2. Repairing Windows Registry
  3. Nasty Bot Has Used My Bandwidth A Lot
  4. E-Books collection on Ubuntu
  5. Member List of Link Exchange Programs
  6. Spider-man 3 Free Mobile Themes (HQ)
  7. The Importance of a Sitemap on Gatzet Info
  8. Defeating Spams On WordPress
  9. Ad Destroy 3.1 To Remove Ads From Yahoo Messenger 8.1
  10. Another Internet Explorer 7 Vulnerability

1 comment for this entry ↓

  • 1 Ken Reidy // Oct 1, 2007 at 5:15 am

    Yeah… I’m agree with you, just try fresh installation of WP ‘Dexter’ in new subdomain/directory first, before upgrading it on the running blog. Or, make sure all plugin that incompatible has been deactivated before upgrading on running blog. However, making SQL Database backup is always great choice

    There’s no warranty if your blog running well in WordPress 2.3 beta3 (or RC1) –I assumpted that you upgrading to WP beta version previously– and still running well while then upgrading to WP. 2.3 Final Release. I’m already feel it, and the worst I didn’t make any backup. Pyuihhh……

    Sorry if my English not so good….

Leave a Comment